Bank of Ireland - Partial outage
Incident Report for Tink providers UK
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Apr 24, 2024 - 13:58 UTC
Investigating
We are currently investigating an issue with Bank of Ireland UK
Posted Apr 24, 2024 - 13:23 UTC
This incident affected: Bank of Ireland.