Issue with Tesco Aggregation service

Incident Report for Tink providers UK

Resolved

We experienced an issue with Tesco between 1:20am CEST and 2:20am CEST.

Manual refreshes were only partly completed in this timeframe. ~80% of all users were affected.

Performance has since returned to normal. We apologize for the inconvenience.
Posted Jul 08, 2025 - 06:37 UTC