TSB Outage

Incident Report for Tink providers UK

Resolved

This incident has been resolved.
Posted Dec 07, 2025 - 05:04 GMT

Investigating

Investigating - Tink automatic monitoring service has detected a service outage.

- Affected flow(s): auto refresh | manual refresh | payment initiation
- Affected users: 90%
- Start time: 2025-12-06 22:14 CET
- Bank side error: Investigating
Posted Dec 06, 2025 - 21:34 GMT
This incident affected: TSB.