Issue with New day service
Incident Report for Tink providers UK
Resolved
We experienced a partial outage between 18:30-19:00 CET.

This issue effected New day pulse and New day Debenhams branch.
This affected around 10% of all refreshes.

Performance has since returned to normal. We apologize for the inconvenience.
Posted Apr 21, 2024 - 18:26 UTC
This incident affected: New Day Bank.