Zempler - Degraded performance

Incident Report for Tink providers UK

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Apr 26, 2025 - 07:22 UTC

Investigating

We are currently investigating an issue with Zempler
Posted Apr 26, 2025 - 01:28 UTC
This incident affected: Zempler.