NatWest - Major Outage

Incident Report for Tink providers UK

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Sep 22, 2026 - 15:14 BST

Investigating

We are currently investigating an issue with NatWest - Universal.

- Affected users: 100%
- Affected flow: Manual authentication
- Start Time: 21.09.2026 18:00 CEST
- Provider name: uk-natwest-universal-ob
Posted Sep 22, 2026 - 12:04 BST
This incident affected: NatWest.