HSBC Kinetic Open Banking - Partial Outage
Incident Report for Tink providers UK
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 07:52 UTC
Identified
We have identified the issue and are in contact with HSBC Kinetic Open Banking for further information. Authentication and Payment Initiation are affected.

We will update when a significant change to the situation occurs.
Posted Apr 10, 2024 - 13:15 UTC
This incident affected: HSBC.