TSB - Degraded Performance

Incident Report for Tink providers UK

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Mar 28, 2025 - 06:09 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted Mar 28, 2025 - 00:27 UTC
This incident affected: TSB.