Santander - Major outage
Incident Report for Tink providers UK
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Apr 21, 2024 - 10:38 UTC
Investigating
We are currently investigating an issue with Santander.
Posted Apr 21, 2024 - 03:29 UTC
This incident affected: Santander.