Natwest - Partial Outage

Incident Report for Tink providers UK

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Jun 06, 2025 - 15:02 UTC

Investigating

We are currently investigating an issue with Natwest.

- Affected flow: [Manual authentication and Payment Initiation.
- Start Time: 2025-06-06 10:18 CEST
- Bank side error: We observed increased ratio of cancellation during payment initiation and manual authentication.
- Provider name: uk-natwest-oauth2
Posted Jun 06, 2025 - 09:28 UTC
This incident affected: NatWest.