Newday Bank OB - AIS degraded performance
Incident Report for Tink providers UK
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Apr 08, 2024 - 08:31 UTC
Identified
We have identified the issue and are in contact with Newday Bank for further information.
We will update when a significant change to the situation occurs.
Posted Mar 20, 2024 - 19:08 UTC
This incident affected: New Day Bank.