American Express - Degraded Performance

Incident Report for Tink providers UK

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Apr 15, 2025 - 07:11 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted Apr 15, 2025 - 03:22 UTC
This incident affected: American Express.