Arbuthnot Latham - Major Outage

Incident Report for Tink providers UK

Resolved

The issue has been resolved since 06.12.2025 at 22:30 GMT. We apologize for this inconvenience.
Posted Dec 07, 2025 - 12:02 GMT

Investigating

We are currently investigating an issue with Arbuthnot Latham.

- Affected users: 100%
- Affected flow: Manual authentication | On-demand Refresh | Background Refresh
- Start Time: 6.12.2025 14:40 GMT
- Bank side error: 503 responses from the .well-known endpoint
- Provider name: uk-arbuthnotlatham-ob
Posted Dec 06, 2025 - 14:59 GMT
This incident affected: Arbuthnot Latham.