First Trust Open Banking - Major outage affecting Account Information Services

Incident Report for Tink providers UK

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Apr 24, 2025 - 07:34 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted Apr 23, 2025 - 18:34 UTC
This incident affected: First Trust.