American Express - Degraded Performance

Incident Report for Tink providers UK

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Apr 12, 2025 - 11:05 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted Apr 12, 2025 - 05:12 UTC
This incident affected: American Express.