Chase Open Banking - Major outage affecting Payment Initiation Services

Incident Report for Tink providers UK

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Jun 15, 2026 - 21:12 BST

Identified

We are currently investigating an issue with Chase

- Affected users:  [100]%
- Affected flow:  Payment Initiation flow
- Start Time:  [15/06/2026] 14:41 BST
- Bank side error: Payments remain stuck in Pending status and do not reach a final state
- Provider name:  uk-chase-ob
Posted Jun 15, 2026 - 15:26 BST
This incident affected: Chase.