Virgin Money planned maintenance

Scheduled for Apr 27, 22:00 BST  -  Apr 28, 01:00 BST

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 24, 2026 - 16:04 BST

Scheduled

Nationwide will perform a planned maintenance on 27th April 21:00 (UTC) for about 3 hours. During this time, the AIS and PIS services will be affected.
Posted Apr 23, 2026 - 08:00 BST
This scheduled maintenance affects: Virgin Money.