NatWest Open Banking and Royal Bank of Scotland Open Banking - Variable Recurring Payments - degraded performance

Incident Report for Tink providers UK

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Jul 10, 2025 - 11:26 UTC

Investigating

We are currently investigating an issue with NatWest and the Royal Bank of Scotland.

Variable Recurring Payments are currently facing a degraded performance. An update will be posted when a significant change to the situation occurs.
Posted Jul 07, 2025 - 11:11 UTC
This incident affected: NatWest and Royal Bank of Scotland.