Virgin Money - Degraded Performance in Account Information Services

Incident Report for Tink providers UK

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Apr 17, 2025 - 20:45 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted Apr 17, 2025 - 16:09 UTC
This incident affected: Virgin Money.